Half-Life basics, tutorials, downloads - Helpdesk, ask questions here


#711

4 posts were split to a new topic: NGHL Slow Motion


#715

Hello SourceRuns members,

Thank you for the amazing work youve been doing. I have a little problem which Ive been stuck with for quite some time: how do I use commands such as “sv_trigger_…” in mods other than Bunnymod?


#716

You don’t, it’s a Bunnymod-specific command.


#717

Well, that’s a shame. Then what tools do you guys use to view triggers on certain maps? BSP Viewer?


#718

Yes, that or you can decompile maps and view them in Hammer.


#719

I see, thanks for the answers guys. Gunman Chronicles`s grown on me recently and I tried opening some of the maps in Bunnymod via copying the necessary GC files directly into Bunnymod folder. Theoretically, would this method work? I find these sv_trigger settings really handy.


#720

I remember Nico making a few videos showing off some Half-Life weapon-related stuff in Gunman, so I’m pretty sure you can play GMC maps in Bunnymod Pro.

I also remember Takyon mentioning that you could use the BPro DLLs in Gunman to view triggers, but the rest of the game was very buggy (which is expected since the code differs alot).


#721

Copying the maps over works just fine. Just copy the maps and WAD files, from what I can tell all bunnymods sv_trigger stuff still works just fine this way.

Like PJC said it’ll run in the HL1 engine so beyond viewing triggers there isn’t a lot else you can do though.


#722

I’m not entirely sure if this is classified as a Half-Life problem, but it is related to Half-Life so I’ll request for help here. When trying to turn off vsync for hl.exe in my NVIDIA Control Panel settings, it springs back to the default setting. I set it to “off” and press apply, but upon exit and reopening, it is put back to default. If it helps, I’m using a Geforce GT 640 (Yes I know I need an upgrade). I seriously need to get 100fps in NGHL because I would like to start playing scriptless, and I think this is the only way to get more than 60fps. My fps_max is set to 100. If anyone here has in any way discovered a useful solution to disable vsync/achieve 100+ fps, please assist me in my annoying problem. Thank you for your time.


#723

Not sure the font size is necessary, but I had similar issues.
I just done all you’ve said as admin and it worked right away.

also, inb4 should be using BXT


#724

What does BXT have to do with it?


#725

I run everything as admin by default so that can’t be it. :’(

EDIT: And yes I use BXT now but I’m not sure what relevance that has to this problem.


#726

Yo, SuperPcow.

I kept getting that same issue with vsync again other day but I sorted it out. Dunno if you have yet or not but try this.

go to device management and roll back your Nvidia drivers. Don’t worry if it deletes them, just re-install them again. restart your computer and it should work! It did for me anyway! Also, I recently de-selected “show programs only on this pc” and selected the HL.exe it has in its list and that worked too. So you could try that too!


#727

I am having trouble on scripts please help!
(I am not really sure about how to bind the scripts so correct me if that’s the problem)
For the bhop I use bind space +bh but I can’t seem to get consecutive hops on straight surfaces and sometimes not at all!
For the object boost I use bind v obbo and it says unknown command: obbo
I tried to read more on http://elxdraco.net/forum/viewtopic.php?f=7&t=54 but the page failed to open so please help!
Note: I am playing on NGHL(full) downloaded from link in this thread
Note2: Game is running in 100 fps if that helps


#728

In order to get consistent hops with loop scripts you need to use specific fps values such as:
83.(3) 111.(1) 125 250 333.(3) 500 1000

Assuming you’re using obbo2000, use this instead:


#729

Thank you for the reply but considering the object boost scripts is @100 fps do I need to edit the alias to switch the fps?


#730

Yes you might need to, you can do that like this:

//assuming you have wait table executed //if there's no fps_max at the beginning of jump loop script just add fps_max <desired value> at the end in case it's needed alias obbo2000 "fps_max 100;+jump;w;-jump;+use;w11;-use"


#731

i was searching for a fix for a long time, did not find clear results int the internet, when playing hl1 im getting random frame drops, when using fps_max 5 for the changelevel delay the fps goes randomly to 1000 sometimes, this is really annoying me since npcs react differently with these fps drops, i tried running the game with opengl and d3d, i also tried out -nofbo -nomsaa (non of that worked)
the framedrops are killing so many runs, and make the game unable to react to some inputs (mousewheel inputs, since im not getting the changelevel delay, and losing 50 u/s sometimes from floor friction)
help please! im not the only one having this problem :’( :’( :’( :’( :’( :’(


#732

I hope I got your issue right.

What binds do you use for changing fps?


#733

You got good hardware and graphics and all that?