blamod


#81

Apparently one of those is vector and one of them is massive.

The tricks video is al-right… at the moment I’m just looking for streams of tricks I can do rather than just individual stuff. Mind helping me get some of the cut scene’s to work so I can free up more of the map? :slight_smile:

After that I just need to learn to edit. I have a pretty hilariously “TYPICAL” intro for the rest of my speed running stuff though. :smiley:


#82

The current version of blamod I posted in the repo-thread has all scene files I could find in the gcfs. Some of the scripts got fixed this way, others didn’t. It seems like some events simply got renamed in the update (like alyx_bend or something) because if you look for the respective files that are named as missing in the console, they don’t seem to be anywhere in the gcfs.

As for the vector, I got your question all wrong. Didn’t know the program serif ;> However, it’s a commercial product and the format doesn’t seem to be supported by Inkscape which is the only thing I have at my hands to edit vector graphics. Any chance I can get it in a more commonly used format?


#83

Vector graphics can only be opened by the software they were created in. He can give you a massive picture if you like.


#84

YOu need to extract the ones from the shared GCF (Both the shared GCF Files), then the HL2 GCF, then the EP1 GCF and finally the EP2 GCF, you need to do it in that order, overwriting any existing ones and that seems to fix them all for me.


#85

Tried that, but it still doesn’t work for me. For instance, that’s the console output from d1_trainstation_04 when you get knocked down by the combine guards:

NPC alyx using alternate collision! -- DISABLED
alyx: unknown scripted sequence "intro_bendover"
Dynamic prop blackout: no sequence named:exit1
CSceneEntity alyx :"Alyx" unable to find gesture "A_gesture13"
scenes\trainyard\alyx_greet01.vcd repositioned tag: extreme : 0.205 -> 0.301 (scenes\trainyard\alyx_greet01.vcd:Alyx:A_bg_acc_dwn_left)
CSceneEntity alyx :"Alyx" unable to find gesture "A_gesture03"

Could you upload your scenes folder?


#86

I’ve got everything except the 2 scenes where you get knocked down working (That one and the one in Breen’s office). The game crashes whenever you tr and enter “ent_fire point_viewcontrol kill(or disable)”


#87

You never uploaded your scene’s folder. :-\

Can I have? :smiley:


#88

I’ll just leave this here.


#89

Awesome, because I couldn’t find mine :stuck_out_tongue:
I lost it in my whole forget-to-backup-all-of-steam-folder-before-formatting mistake.


#90

Nope, still the same:

alyx: unknown scripted sequence "intro_bendover" Dynamic prop blackout: no sequence named:exit1 CSceneEntity alyx :"Alyx" unable to find gesture "A_gesture13" scenes\trainyard\alyx_greet01.vcd repositioned tag: extreme : 0.205 -> 0.301 (scenes\trainyard\alyx_greet01.vcd:Alyx:A_bg_acc_dwn_left) CSceneEntity alyx :"Alyx" unable to find gesture "A_gesture03"

Beating d1_trainstation_04 remains impossible like this.


#91

Yeah, I had the problem too, try extract scenes\trainyard\alyx_greet01.vcd from the HL2 GCF.


#92

Nah man, that’s what I’ve been doing all along. It simply doesn’t work. Even extracting the original map from the old HL2 content gcf doesn’t fix it. The engine is seriously going on my nerves again already. It appears to be way too convoluted.


#93

Cool is now the official Scene’s guy. Nominated for awesomeness.

Downloaded and put in the right folder and now most of the scene’s work! :smiley:


#94

Yeah, I don’t see Alyx either. I’ll see what I can do with scenes\trainyard\alyx_greet01.vcd

Edit: Fuck it, remove Alyx from the map game.


#95

Well, to be honest, this only matters if you wanna fool around in HL2 using this mod and actually beat the game. The actual plan was just taking certain maps that suited the gameplay style and remove the necessary stuff there (something no one did so far either :p). d1_trainyard_04 was not on my candidate list iirc.


#96

Well, actually, last night I decompiled d1_canal_11 and removed the gate along with some unnecessary clips, I’ll be uploading that when I get back to my desktop. I’ll keep messing around with the VCD and see if I can fix anything, fucking game.


#97

You said you had trouble with the text of the timer, tooley. Which resolution did you use exactly? I tested every resolution on my system now (4:3, 16:9 and 16:10) and they all displayed all HUD items properly. The font size is based on the vertical screen resolution as defined in the ClientScheme.res file in the blamod/resource folder. The timer uses the “Default” font section. The highest y-resolution it covers is 10000 pixels which is a lot…

Edit: Nevermind. I watched the clip again and noticed the HUD setup is different from the current version. Guess I already updated it when you mentioned the problem earlier. So that’s sorted out already. Gonna look into getting the heightmeter working properly next.

Edit 2: Thinking about dropping the heightmeter altogether. The reason I wanted to add it was that it was also available in Q3 Defrag. Guess it doesn’t really have a point in blamod. Thoughts?


#98

I didn’t really want the height meter in the game.

What I REALLY want is shotgun boosting and orb boosting. I may actually go crazy into map editing during the holidays so that I can create some interesting maps for this mod.

If I get good enough I may actually end up editing all of the original game maps to be speed-runnable from start to finish. WE CAN DREAM GUYS!


#99

I don’t dream.


#100
I don't dream.
When was the last time you slept Jared?