Windows CMD console opens but game doesnt start

pls HELP! so I tried helping my friend start speedrunning and source unpack wasn’t working so I just copied my source unpack folder and gave it to him. When he starts his .CMD it doesn’t start the game let alone the engine no errors pop-up so I’m guessing the .CMD won’t start the engine and the CMD opens and runs through all the code it just doesn’t start the engine and portal doesnt doesn’t start. He does have an account that has portal it is just after running the .CMD it just sits there saying its been done successfully and that’s the end of that .

(P.S he does have a weird program that uses .dat files so one of the files does have an associated program if that could be the issue)

Does just running hl2.exe work? It’s hard to say why it’s not running, could be an antivirus thing for all we know. Try troubleshooting the launching of batch files.

I tried having him launch Hl2.exe before and nothing happened he also doesn’t have any antivirus installed only stock windows stuff