Why does my old version of Portal 2 crash at startup?!?


#1

This is really frustrating. I followed https://forum.speeddemosarchive.com/post/portal_223_920.html to set up SKIDROW Portal 2 with RevEmu to get Reportal and BSG to both work. My rev.ini is exactly the same as DemonStrate’s and my RevEmu log displays no errors, but the moment Portal 2 gets past the Valve logo it displays the “has stopped working” window twice(!) with a BEX then revLauncher crashes too with an AppCrash. The problem seems to be in a steamclient.dll of some kind, but I don’t know whether it’s the RevEmu one or the standard one that’s to blame. Does anyone have any clue why this may not be working?

EDIT: Also this happens if I’m using -window; if I start in fullscreen it instantly freezes and I have to hold down my power button to kill my PC.


#2

Did you take this into effect as well?

By bad. I missed a critical part of the rev.ini: SteamClientDll=steam\steamclient.dll

You need that in there or the registry will not update the linkage to the steamclient.dll properly. It is different than the “SteamDll”, because the client dictates if you are connected to the revEmu ‘Steam’ or not.

Edit: Another thing I missed:
The portal2.exe I am using is from Steam’s Portal 2. So, it is not any kind of cracked EXE. It is the real game’s EXE.

Edit2: Crap! Missed another thing:
Replace the client.dll and server.dll in portal2/bin with the one’s from this archive:
http://dl.dropbox.com/u/45123651/sr-port2cf.rar


#3

Yes, I did, though I think I know the problem now. The latest Portal 2 has CEG, which revLoader can’t handle. I read that you can remove CEG by deleting the executable, verifying the game files, and copying it out before Steam can reapply CEG. I’ll try this later on when I’m not busy.


#4

Nope, that didn’t work. I think Steam probably patched that. I guess I could try cracking the CEG. That or see if anyone else has a CEG-less portal2.exe…

EDIT: Just realised CEG came out in 2009 and is applied to DLLs which I’m replacing; it’s probably not relevant.


#5

Oh! I think I know the problem now. I copied client.dll and server.dll into the wrong bin folder. I put them in the right place and now I’ve delayed the crash a tiny bit, though now I need to add back the original SKIDROW files, which means re-extracting the installer stuff. Dammit.


#6

Well, I tried launching the SKIDROW version on its own and it is now crashing with the same error. I am so confused.