Trouble with Office Complex guard skip


#1

Sorry to spam this old thread, but I’m having some serious trouble with a trick. I can’t get the guard to open the door in the ‘office complex’. I’ve tried the grenade scare. I’ve tried killing everything in the run. Most of the time he runs to it and just slowly turns around. Are there any tips I can get for getting this asshole to open the door?


Half-Life basics, tutorials, downloads - Helpdesk, ask questions here
#2

http://wiki.sourceruns.org/wiki/NPC_Abuse Hope this helps


#3

YES! Thank you! I didn’t know you couldn’t save in the same chapter. I was trying to quicksave then do it.


#4

Does anyone actually know why that is? (Why you can’t save in the map for NPC abuse to work?)


#5

Gotta look into that. If it is due to something in either client or server dll, then I should cvar-hook it in the TAS mod.


#6

if you can’t load map B, go back to A and back to B and try thr trick, I assume it’s to go with HL1, HL2 or HL3 files being made


#7

It has something to do with NPC waypoints.

My theory is that they get carried over to the next map, and if you just load the map simply (or a save) the waypoints will be gone and will not allow you to push NPCs into doors.


#8

Keep in mind though, if saving the game is made possible then one can do a quick weapon switch in We’ve Got Hostiles. That would be cheating.


#9

Of course this would only be legit if no save-tricks are used. I thought about that.