Source Unpack CFileSystem_Steam::Init() failed


#1

Everything related to source unpack for me does not work, and by that I mean no game will boot. HL2 doesn’t boot, Portal doesn’t boot, Portal mods don’t boot, HL2 mods don’t boot.

I get this error -

Tried with steam on, tried with it off, tried in offline mode, tried with computer upside down whilst eating Chocolate Eclair cake. NOTHING WORKS. Would just replace all the files with the .zip backup I made but I lost it.

Help plz.


#2

have you read the README.txt?


#3

Sorry to sound rude but, I’m not stupid. I read the damn readme first thing like any sane person should. It was even the first thing I went to when I started having this problem. I’ve had the Source Unpack since I joined the forums, no idea why its screwing me over now.


#4

I’m sorry, I just tried to help. It was the only thing I could think of to answer your question.


#5

This is just a random guess, but that error looks like some Steam DLLs are missing. Try backing up the rev.ini file and downloading and extracting the latest revEmu into your Unpack folder, then replace the rev.ini with your backup. Let me know if it works.

Oh and you can get revEmu at http://rghost.net/private/57870418/270d222533a60e6b5a2d4205c7f5f29b (if you’re not using an ad-block click the download button with the MD5 and SHA1 sums under it). The files you want are in the steampipe_source subfolder in the archive.


#6

Well, I think I found the problem (and solved it.) I noticed in the download there was a steam.dll. I didn’t have a steam.dll, I just added it to the source unpack folder and voila. Works fine now.

BTW: Sorry if i was rude reijerzzz, I had a really stressful and crazy day that day.


#7

It’s ok, don’t worry about it


#8

Source Unpack\bin\steam\ contains all the original Steam DLLs that I took from my own installation back then, including steam.dll. And the revEmu ones should be in Source Unpack\


#9

Although this isn’t a problem, its still a concern. Since I put the new steam.dll in, its apparently been generating a .dat file that my AV (Norton) thinks is a virus. Is it Norton being good for once or yet another mishap?

EDIT: Forgot, in case it helps, the name of said file is this - mbofxufk.dat


#10

Hl2.exe likes to generate hidden dat files with random names when ran through revEmu, my .bat launch files delete them.


#11

Ahh, okay. So its nothing to worry about, then.