Source Unpack 2.4

Source Unpack

Here it is, the new Source Unpack series! With Steam support, Episode 1 & 2 and Old Engine Half Life 2 Unpacks now available!


Source Unpack 2.4 (Portal & HL2) (2.5GB) (v5135)

Episodic Unpack 1.0(Ep1 & Ep2) (3.8GB) (v4104)

HL2 Old Engine Unpack 2.0 (SOURCEMOD)(308MB)(v4044)

It may be necessary to use 7zip to extract these files!


  • Added RInput
  • Added -high -noforcemaccel -noforcemparms -noforcemspd to launch parameters
  • Updated spt to latest version
  • Added vault save and vault demo for Portal
  • Added demo recorder plugin by Maxxuss
  • Removed SEDTDemoInfo
  • Added PortalDemoTimer
  • Fixed working directory issue

Added Standalone Ep1+Ep2 Unpacks by Maxxuss.

OE v2.0

  • Changed to version 4044 for compatibility
  • Changed format to SourceMod (launched only through Steam)


  • Fixed bad map mixture from multiple versions.
  • Added SEDT
  • Added proper segmenting config.
  • Added better ReadMe


  • Fixed Steam not showing that you’re playing either game.
  • Added Episodic Unpack to the Wiki.
  • Updated Executables.


  • Added RInput.
  • Fixed Steam DRM.
  • Added older binaries for compatibility.
  • Added SPT to Portal.
  • Added Custom binds.
  • Fixed window capture issue.


  • Added Steam DRM.
  • Updated binaries.
  • Removed “Rev” Steam Emulator.
  • Added Source Pause Tool.
  • Added Segmenting Config.
  • Updated Readme.txt.
1 Like

Adding RInput to Soure Unpack seems like a bad idea.

RInput is a good program but I feel like adding unrelated software that people might like could turn into a slippery slope. Anyone who wants to get rid of ingame mouse acceleration is obviously capable of downloading and applying it themself.

And another small thing, the custom binds that are included only make sense for american keyboard layouts.

Kinda sorta agree with Mikael, although RInput is probably not going to do harm. One thing I don’t like though is how SPT is duplicated all over the place. Since pretty much every Source game mounts HL2 (certainly Portal does anyway), the DLL only actually needs to be stored in the hl2 directory if I remember correctly. I can fix it myself of course, so no big deal. Also I hadn’t looked at the binds, but yeah, it seems silly only including US binds. Most people who know what they’re doing can customise stuff, but most people who really need this are probably those who are new.

Regardless, thanks for uploading this. I am looking forward to being able to download the episodes since I realised recently that I probably installed them to the wrong engine version for some stupid reason. Plus, being able to not use a sketchy crack seems more comfortable on a semisubconcious level. Not that I really ever cared when playing :stuck_out_tongue:

sadly as silly as it is its kinda hard to make binds for MOTHER RUSSIA when you dont have a BLUE BOTTLE VODKA CAP keyboard

Yea except russian keyboards are basically US with russian letters so there’s no need for a separate layout

Well then why not have a option were you can get any versions of source unpacked not only 2.2
(if none dose it i will then)

uuuhhh… 2.2 is the version of the unpack, which is this distribution of the game(s). The particular build of Source for HL2 and Portal is… 5135 I think (right?), and I’m assuming the episodes will be 4104. If for some reason you want any other version you’ll have to search through obscure torrents and stuff trying to find it (not sure why you would).
Plus there are probably a LOT of builds of Source in existence, probably including internal Valve dev builds that never got released. You can’t just say “here is every game version ever!!!11”

There are separate launch files for each game, the two in the main directory launches either games without Rinput, and the two in the RInput folder included launch either game with RInput. So you aren’t forced to use RInput, and if it bothers you so much just delete the files.

The main reason I included RInput was because I got complaints from some people saying that Source Unpack 2.0 wasn’t locking the mouse in the window and sometimes made the framerate drop when alt tabbing in and out of the game, I recreated the problem and discovered RInput fixed both issues, using older versions of DInput and using DInput8 didn’t work but RInput did so I don’t know of any other solution, so if anyone has that issue, they can try RInput.
Some people just like RInput, so there’s nothing wrong with an optional extra.

The problem doesn’t occur in the Episodic unpack so it won’t be included. its coming soon I promise!

Probably one of the main reasons I made the Episodic Unpack, Episode 2 you had to get through Maxxuss via PM, but could be played even without owning the game on Steam under certain circumstances, and Episode 1 was only available through an ancient torrent with barely any seeders and was cracked, so the few people that ran this game probably would have been running on an illegal version of it.

Wasn’t the cause to this the updated DLLs you tried to use and wasn’t it solved when you put the old ones back though?

That fixed the alt-tabbing framerate issue but not the mouse not locking in the window properly. The steam forums said use a newer version of DInput8, which didn’t work, someone said RInput and it worked. I haven’t found any.other fix for that yet.

Something bad just happened.

I noticed that I was still getting a rev-client.log in my Source Unpack folder, so I tried launching Portal with Steam opened and it turns out that the Steam DRM doesn’t seem to do much. It is possible that I did something monumentally stupid on my end that led to DLLs being swapped around, but I’m pretty sure the download is actually still cracked. I don’t really understand how this could be the case because the whole point of this is to remove revEmu, but this is what I found. ???

The solution I found was to remove all the Steam DLLs from the unpack root and from the bin folder, but just leave the non-cracked steam_api.dll in bin. edit: It might also be necessary to launch with -steam but I’m not sure.

I don’t know if I did something wrong to cause this, but I have a feeling you might have to put up a new unpack :frowning:

EDIT: Also, I forgot to say that before I got it working, Steam wasn’t showing in-game status or giving me the overlay, so there was clearly some kind of emulation going on…

EDIT 2: Since I got it to work, suddenly it doesn’t work again. It can’t find the steam interface even though it could before. Can someone who knows what they’re doing help? This makes absolutely no sense. Fixed by restarting steam… I’ll leave this in case someone has the same problem.

That’s impossible, I’ve tested this extensively and have found no such issue on different Steam accounts with different games on them.

If the account has Portal on it, it’s working as intended.

Are you sure you didn’t just copy and replace the new SourceUnpack with an older version? If you did, that would most likely have left the rev-emu.log there from the old version and a whole bunch of cracked dlls that I removed.

Dammit. I said “with steam open” but meant without. ::slight_smile:

I thought I messed up some DLLs, but I regrabbed the entire bin folder from the installer and there were still some unsigned DLLs. I can’t have overwritten the installer as I was still seeding it for a while (I arbitrarily went with the torrent). The rev log was reappearing whenever I quit the game, even after deleting. Like I said, the way I’m pretty sure I fixed it was to remove all the Steam and steamclient.dll files and just keep bin/steam_api.dll (uncracked), and add -steam to the game launch parameters, though I don’t know if that’s important or not (it was when I didn’t add it that launching started to fail though).

This might be my fault but I have no idea how. There might be nothing wrong but you might want to check.

Ugh, I found the issue.

I had two versions of Source Unpack on my PC, 1.x for testing, then I merged the two and forgot to remove the illegitimate Steam DLLs for the final version of 2.2. I can be an idiot sometimes.
Thanks for the info, mike, I was certain I had this working perfectly. The Episodic Unpack does not have this issue and is still good to use.

All download links will be updated within the next 48 hours.

Installer updated, still waiting on torrent and mirror.

Can I give some feedback? Drop the custom binds for clipbrushes etc.

It took me a while to figure out why clipbrushes show all of a sudden when I found out that it overwrote one of my custom binds that I had since a previous version.

That and I like having a clean config and like to know exactly what I bound to what.

EDIT: The custom binds aren’t even compatible with my keyboard layout.

EDIT 2: Why is -console not a standart parameter in the .bat?

EDIT 3: Why the fuck is it even an .exe? It makes unpacking such a horrible horrible and tedious process…

Hey, so I went and too the past couple days to learn EP2 Runs with current strats but… couple issues with the episodic unpack though. For one I can’t figure out how to get this shit in the top right hand corner off my screen witch is apparently defaultly set on. (it’s like some sort of debug text that keeps updating) And every time I close the game, it un-does all of my key binds. So if anyone could help me with this (especially a way to get that fucking text away) I’d be super happy thanks.

Do “developer 0” and “cl_showpos 0” in the console to get rid of that text, if you want to keep your positional info don’t enter cl_showpos 0.

As for the config, make sure your you’ve got hl2.exe set to run as an admin, and your game folder is not read-only (sometimes the installer makes the folders read only).

Set your binds in game and do “host_writeconfig”, alternatively, you can manually add all your binds to autoexec.cfg in the ep2/config folder.

So in HL2 Old Engine any time I try to load a save the game crashes, so i just go and untick the box that says read only as instructed above, only it doesn’t seem to keep the setting. I’ll apply settings, go into the game and it’ll be ticked again, is this some launch setting that I need to change or something else? Tried the latest unpack versions of portal and HL2 and they both keep the setting after I apply it, so any ideas how to fix this?

Ahhh thank you bitrain I have everything working fine now, with the game at least. only issue now is source splits will not work with my game at all, so… RIP.

You can try download these splits:

Run LiveSplit as administrator, open the splits, right click>edit splits, Open the game, Click activate in the Edit Splits window, and it should start the timer automatically and split every time you change map.