Sony Vegas only importing audio


#1

For some reason it’s started only putting the audio from the avi files when I drop them in. If anyone knows the solution to that then that would be awesome. I’ve tried downloading a whole array of codec’s and it has no effect. :frowning:

The other solution is whether anyone knows a decent avi to wmv converter.


#2

What version of Vegas are you using? I use 9 and it exports are a wmv


#3

9c


#4

Use movie maker, it’s so much better.


#5

Morning, if Vegas doesn’t recognize the fourcc of the clip you’re trying to import it’ll only import the audio stream without issuing a specific error message as to why no video stream was imported. For instance, Vegas can’t natively decode XviD streams (well, Version 7 can’t which is the last version I used). So I guess that’s where the problem’s located. If you need something to just re-encode a clip I suggest you use Avidemux since that seems to be a very flexible program these days.

I really hope this was just a bad joke…


#6

Check if the raw AVI is larger than 2GB. If it is, then the video will most likely be corrupted. Try repairing it (I’m usually able to do this by just opening it in VLC and it’ll ask me if I want to repair), but if it doesn’t work you’ll just have to record it in segments.


#7
Vegas can't natively decode XviD streams

I can’t remember too well but I’m pretty sure I used XviD next time I record I’ll try and use another… instead.

Check if the raw AVI is larger than 2GB. If it is, then the video will most likely be corrupted. Try repairing it (I'm usually able to do this by just opening it in VLC and it'll ask me if I want to repair), but if it doesn't work you'll just have to record it in segments.

It was only 66mb. Also I think you meant demo’s. :stuck_out_tongue: