Sin episodes Emergence?


#21

Concerning your “se1_docks02” demo: It’s possible to do a dale-jump with the garbage-can from the platform that you jump down from (near that construction thing that opens the gate on se1_docks02). What I mean is that you can actually jump from that platform onto the roof and drop down where you landed with your skip. I’ve only managed to do this jump ONE TIME a couple of days ago and I didn’t record that time…

The hard part is that you need to run with the garbage-can through the door, and it’s just big enough to fit so if you’re just a little bit off then you’ll hit the doorway. But it saves a lot of time!


#22

Good to know, that roof looked quite high so I didn’t try to get there.

It doesn’t matter if it’s difficult, it only needs to be done once :wink:


#23

Messed around a bit again in se1_docks03, added a demo, at first I was going for one of those windows you can see at the beginning which wasn’t hard, but then I thought why not go for the roof, few hours messing with the door, getting close but not quite there and then I started using grenades and a few minutes later I made it, don’t know how much it skips but looks nice.

Also added vending machine demo, you probably allready knew that spamming use to those gives medpacks, recorded it with use-script for illustration or something.


#24

Holy shit, that nice grenade+slope jump looks great! :slight_smile: According to the old speedrun it takes about 30 seconds to go that distance otherwise. Just 2 questions: How long does the setup take and is it possible to survive the fall down (since you died in your demo)?


#25

Damn Cloudfare errors, tried to reply for hours yesterday…

Question 1: The difficulty in the setup is getting the door out fast, it gets blown in and it lands flat on the floor and because it’s surprisingly same width as the doorway, it has a tendency to get stuck and then falling of your hands, and once you grab it again and get it out, it’s usually oriented in an awkward angle + there are 5 enemies outside, 2 of them next to the doorway which might be better to get disposed of.

The method I might use is shoot the first guy in doorway as he rushes in, pull door (hopefully) through, shoot second guy in corner, grab door and put it in it’s place (throw and hope for best?). So if all goes well, it shouldn’t take longer than some seconds. Alternate method could be using a table, it’s much faster to get it out of the door as you can throw it straight through before shooting anyone.

This is also afaik the first place where you can get the shotgun, it’s on a box above on some pipes and just shooting the box usually causes it to drop down.

Question 2: Not only possible, but easy, there’s some water puddles (google translate) to break your fall on, I lost my focus because I was so surprised to make it up there and didn’t know what to do next :stuck_out_tongue:


#26

Damn Cloudfare errors, tried to reply for hours yesterday…

Yeah sorry, the server has been crapping itself for some reason the past week or so. I think I finally found the problem so it should be all good from here.


#27

I’m not really sure if I’ll be running this any time soon; currently I’m just poking around the game and searching for things, and found a small skip in se1_pit01, that saves few seconds, since you just jump on your grenade instead of trodging for the pipe, but still…

I was looking around for something a bit larger or something resembling OOB, but found nothing that’s not already covered in the tutorial…

~Twi


#28

I’ve also been playing around with the game again for the past week or so after dropping it back in August or so, I was going to make a new topic soon and post all my findings but I guess I’ll just end up using this thread.

That’s a nice little time save there. I’ll try and upload a compilation of my findings as soon as I get home today now that theres pressure on me to do so!


#29

Alright, here are the starts and glitches I’ve found so far as you can tell I’ve been mainly focusing on the first part of the game but I have a few skips I’m working on as well for the later parts.

Some of them are based on the SiN Episodes demos that PJC gave me, pretty much just improvements especially for RTA/SS Runs. As you can tell they rely heavily on prop surfing which is cool and pretty easy to do and reliably once you get the hang of it but double jumping on health canisters can be pretty annoying some times and double jumping in general.

As you can tell you can also use some buttons through walls and activate some triggers through brushes with enough force on the player. But that particular skip in the video isn’t useful at the moment since doing it makes a door not open in the next level.

Right now I really wanna figure out how to get the .vmfs to open in Hammer so I can check out the trigger and all sorts of stuff and since the SiN SDK is not working properly I can’t get them to open. Could any one assist me with that?


#30

Ha!
I was so so close about figuring out the object boosting myself, since everything just sparkled when you pushed one object against another.

Your video is freaking cool and makes me wonder how much more can be actually skipped with that glitch.

As far for checking out triggers, I just use showtriggers_toggle (doesn’t need sv_cheats set to 1), and for checking out clipbrushes, I just use r_drawclipbrushes 1 (this one does need sv_cheats 1)

As far as the Hammer is concerned, hadn’t tried… MAybe I’ll look at it a little bit closer after this wave of exams passes.

~Twi


#31

I’ve found only two more instances later in the game where that glitch can skip stuff, but I’m working hard on looking for more and making them reliable.

Hopefully with more people looking for stuff we can make more progress!

The problem with those commands is that they don’t show what the trigger actually does or what it affects which is the information I need. I’m making some success with hammer but I keep getting this error

Any Source/Hammer wizards out there?


#32

Been looking at this game on and off for a while now but after looking at the new stuff from Lesterre I decided to go through it once again using the new strats, so far it is way more enjoyable to execute and I managed to find some more spots for prop surfing, not sure what other places you had where you can use buttons through walls though.

Only had one problem so far, while doing the docks after having had the long boring conversation and the boat starts to catch on fire with mutated enemies and stuff, one of the doors with a wheel on it won’t open no matter what I do.


#33

@Lesterre, is there a special setup for using the button through the wall in that video? Whenever I try it I just can’t get it to trigger unless I noclip through the wall and look at it.

I looked at all of the maps in the editor briefly but could only find one interesting thing that I have to look more into.


#34

I haven’t found a reliable set up for it yet! :frowning:

It’d be super cool if you could share some of the new stuff you’ve found would love to see what’s been found.

I actually just set up the game again last night so I might go digging for some stuff tonight.


#35

If you are around to it I can show you on stream tomorrow, go through the whole game from start to finish.