Can't deactive gamepad (Portal Source Unpack)


#1

I’ve started learning Portal Inbounds the last few days using Source Unpack. As I really like messing around with stuff I started using the devconsole a bunch and saw that it is trying to bind keys of a non-existent xbox360 controller.
The setting for gamepads in the ingame options menu is disabled and I don’t even own an xbox360 gamepad.

I have already tried deleting the files “config.360.cfg” and “config.cfg” in both the steam version and the SourceUnpack version of Portal and it still always rewrites the config.cfg in the same way as it was before.
Using “unbindall” and redoing my settings doesn’t work either, as it just prompts the game to redo the gamepad settings again. The config.cfg always ends up in the exact same way.
I tried manually deleted everything with joystick_* or xbox_* in “config.cfg” and still the same result.
I also found a line in “valve.rc” that tries to load a file called “joystick.exec” that doesn’t even exist (well I didn’t find it), but I have removed that line anways.

This is pretty frustrating as I’m trying to work out why the game has lag is some situations that shouldn’t be too much for an intel i5 and ATI Radeon HD 6870 to handle.

Here is a pastebin of my config.cfg: http://pastebin.com/XPjWbtNK (I just opened the game again to generate a fresh one and it still has these settings)


#2

I think there’s a cfg that undoes the 360 controller options. “exec undo360controller.cfg” I think it is. If not then I’m sure you could find it in your cfg folder.


#3

I tried using “exec undo360controller.cfg” (the game even offered auto-complete) but it didn’t do anything. I found a file with that name in “/hl2/cfg”. I also tried copying that file over to portals cfg folder, still nothing. After restarting the game it still says

Using joystick 'Xbox360 controller' configuration
JOY_AXIS_X:  mapped to Side (absolute)
JOY_AXIS_Y:  mapped to Forward (absolute)
JOY_AXIS_Z:  unmapped
JOY_AXIS_R:  mapped to Look (absolute)
JOY_AXIS_U:  mapped to Turn (absolute)
JOY_AXIS_V:  unmapped
Advanced Joystick settings initialized

in the console

EDIT: just tried the same thing for the steam version, same result


#4

Have you tried unticking “Enable Gamepad” under the mouse options?

Your config has “+jlook” at the end of it too, so remove that as well as any other commands with “xbox” or “joy” from your config.


#5

Pretty sure the game always does this. I don’t see how it affects anything.


#6

Pretty sure I said that I did that and I checked it everytime I changed something

Tried that and it still managed to recreate the previous verison of the config.cfg file.

If that’s true then that shouldn’t be the problem why the game has lagg issues. I guess my PC just wants to retire from gaming :-\