Posting had to be disabled unless you’re a registered member due to many spam threads. I wish we won’t have to enable validating, too.




It seems they just registered and continued spamming the way they used to. I enabled email validation so when you register, you will receive an activation link you need to click in the email address you supplied in order to activate your account.If this (still) causes trouble we could modify user groups and stop new members from posting new topics until they have made one or so posts in other user’s topics.


Nice work Samppa, those bots were really annoying.It’s because of the “Invision Power Board-system” (that runs these forums) that makes it possible for bots to post these “commercial-threads” right?


Yes, the bots are aimed to spam (at least) IPB. This board was spammed only because it uses the same code as very many other boards. The bots were likeky to find this board with a search engine (we’re not listed in the board directory on InvisionFree home page); not by searching “hl2dq” but rather something like “invision” and going through all of the results.


I guess (some of) the bots use an email address that sends the validation link straight to them (or rather to a central-fake-email-spambot-validation server or whatever).It is quite annoying to everyone I have to go back and forth with the settings. However, I disabled email validation since it doesn’t stop the bots. New users are members of the group Beginners, and they cannot post new topics until they have made one post in someone else’s topic and promoted to the regular group, Members. Hopefully this helps.Unfortunately everyone has to post once to be promoted no matter how many posts they have made so far.


You should upgrade to a newer version of IPB, invisionfree is packed full of flaws and glitches that bots can exploit. Even IPB v1.3 (which is free) is better.


Samppa, I don’t know why this problem exists but maybe you know?Some HL2DQ members are having problems with posting on HL2DQ, I’m speaking for them:;start=67#68As doxliy says, they get this error: “Sorry, you do not have permission to reply to that topic”