AutoHotkey Jump Script


#1

Hey,

I found a cool script that floods spacebar and other buttons. :slight_smile:

Here it is:

$*space::
Loop
{
   if not GetKeyState("space", "P")
      break
   Send {Blind}{space}
}
return
$*e::
Loop
{
   if not GetKeyState("e", "P")
      break
   Send {Blind}{e}
}
return

Currently it floods spacebar and use key (e for default)

I tryed to do ABH with it (using Control to crouch) and it worked fine!

There’s only one problem. After I release the CTRL and Space buttons I am getting Message Box that says

71 keystrokes received in las 0ms

Do you want to continue?

[YES] [NO]

Is there a way to remove this?

BTW - when are your website is comming? I could use some help to create it using PHP-Fusion (or other CMS)


#2

What does blind do? Also we’re not the best AHK experts. We’ve made a grand total of 3 useful scripts and it’s all based on the one that dalelewill made anyway. :stuck_out_tongue:


#3

I interpreted it as it just blindly spams the key, thus not caring about time or number of clicks etc. But what do I know?


#4

Umm, idk what the Blind does… I just found it on AHK forums and tryed to use it, so it worked fine for me :stuck_out_tongue:

Any ideas how to disable that message when releasing keys?


#5

I have no idea. I checked with my AHK and I couldn’t find an option correlating to that. Perhaps you have a newer version where such an option exists, or perhaps I’m just a total newbie when it comes to AHK.


#6

http://www.autohotkey.com/forum/topic37801.html

Here is the source I found the script from. I modified it a little in here, but it is the same.

Read the 4th and the 5th post.

The guy said that when holding CTRL and Space, the SpaceBar is keeping released, and the second guy included {Blind} Options and then I guess it worked fine, so I think that option makes AHK ignore the Space Bar being held, but still operates the SpaceBar function.

Sorry for my bad english - I hope you understand what I wanted to say lol :slight_smile:


#7

I totally understand, and that’s totally awesome! With the script I have I can’t use ctrl as crouch, which is something I really want to do. You just made my AHK so much better! ;D I’m not sure if I can help you with the problem you have, though. I’ll look some more at my AHK to see if I find something. But really, thanks for the blind command!

And by the way, your English is perfect.


#8

Hmm. That thing seems a bit like some kind of debug mode. Look through the AHK site and have a look for things of such nature. :wink:

EDIT: Try the following command in your script:

#KeyHistory 0

Failing that try doing something with the command shown in the link:
http://www.autohotkey.com/docs/commands/ListLines.htm