Source Unpack 2.3


#41

This didn’t work, but when I returned the folders to there correct positions the game loaded. The same “client and server .dlls” are missing error pops up, but the game loaded yet still wasn’t on the old engine and was very glitchy.

Screenshot:


#42

Try installing SourceSDK base 2006


#43

That didn’t work either, I might as well torrent the old version at this point lol.


#44

Try this https://mega.nz/#!hA11jJDD!j8tnF1bay7AyzJCNswNsbhc_0bKU1xFmuCqk5TnYGVc


#45

And where do I put this?


#46

nowhere, just run the batch file or hl2.exe with Steam open.


#47

Thanks, that worked!


#48

So μ (https://sourceruns.org/index.php?action=profile;u=3229) bought an original retail DVD of Half Life 2 from Ebay a few months ago and uploaded it to see if anyone could get the game to run on modern OSes.
Eventually I did get it to run but I’d like to document the process of how I got it to work and some info on why it doesn’t work in the form of a forum post because some may find it interesting and may be useful in the future for game collectors.

Unsurprisingly, it didn’t work AT ALL at first, here are the main reasons why it didn’t run:

  • The installer required you had the game on a DVD to install it, just having it run from loose files in a folder would show a SecuROM error, the fix for this was easy because you can just mount the files as an ISO which mimics a DVD in some ways (Later versions of SecuROM prevent you from using ISOs, this one is pretty old so it doesn’t recognize the difference).
  • Steam was REQUIRED for it to run, so when you installed Steam along side HL2 on the installer Steam would open and automatically update to the latest. Problem is, HL2 wouldn’t detect the latest steam version and would produce an error upon opening HL2 with the latest Steam, so the solution to that not to update steam on an offline VM, however you have to log into Steam so HL2 can verify that you own the game because upon opening Steam after installation HL2 will be bound to your account, without being logged into Steam at least once the game game won’t launch. This of course means that you have to be online to log into Steam, which will then update it automatically, It still doesn’t work.
  • The game was packaged in GCFs. Easy fix, you just unpack them with GCFscape, but the Steam problem persisted though, so I tried to get it working using the GCF loader option on Rev Steam Emulator enabled in the .ini file, still didn’t work for unknown reasons.
  • SecuROM required the game to be run with the DVD in the computer. This only happens on the retail version, on the Steam version it just requires you to have Steam open, so why didn’t it work with just the DVD in and without Steam? Valve works in mysterious ways, Steam had to be logged into at least once to play the game despite the SecuROM DRM being present to verify that you own a legit copy of the game anyway, kinda strange but the problem remained.

So what the fuck did I do to get it working? Sounds like a nightmare.

Turns out Megagames.com has an archive of crack releases by pirate groups from 2004, so I downloaded a bunch of different cracks to see if they worked. A lot of the cracks are very different, some of them are NoCD patches which enabled you to play the game without the disk in but only with Steam and some were NoSteam patches which let you play the game without Steam but only with the disk, the majority of cracks were just CFGs that stopped that AI disabled bug from happening.

Neither category of crack was any use to me but combining a crack that removes the use of the hl2.exe with SecuROM embedded in it and a crack that removes the need for Steam to be enabled worked perfectly.

So here’s what I did:

  • Mounted the ISO, opened the .CAB files the HL2 installer uses with 7zip and extracted all the GCF files to a folder.
  • Extracted those GCFs with GCFScape and organized everything into the Source Unpack format.
  • Removed the SecuROM hl2.exe and replaced it with the NoCD patch hl2.exe, and copied cracked bin files from a NoSteam patch into the root folder.
  • Then tried to run hl2.exe alone, but some DLL factory client error appeared, so running making a batch file with “-game hl2 -steam -novid” fixed it and it launched fine, the game runs perfectly.

So that’s how I did it, hope you found it interesting.

Unfortunately I can’t release this to the public because I can’t get the game to detect if your Steam account has HL2 on it, I can’t even get it to detect Steam at all. Unless you REALLY want this version of the game just send me a PM on the forum or email me at bitrainy@gmail.com with a link to your Steam account so I can see if you own HL2 or not, then give you a link to it.

Pls excuse formatting


#49

Thanks for taking the time making it working. :slight_smile:


#50

Noice.

Must have taken alot of time to get it working!


#51

Is the original version of portal (where you don’t get stuck oob) ever going to be released in source unpack?


#52

You can grab it from shady websites.


#53

It causes “no enough space” for me


#54

Out of curiosity I just tried this. There’s really no need to use it at all. The inability to change FOV to 90 without sv_cheats was enough for me to dislike this version, but there’s just no advantage of not getting stuck while Oob.

The noticeable differences I noticed were:
No getting stuck while OoB (Slightly affects escape_00 in Oob)
No quantum crouch (Affects 06 if you don’t use seam shot)
No radios outside of the vault
Audio skips around and is very annoying

I will admit though, it’s oddly satisfying to be able to move while Oob.


#55

I imagine it’s not really useful for Portal itself, but I’ve always wondered if it’d be useful in some mod. Come to think of it, you could possibly use it for HL2DP or something. Though on that note, something I considered doing (but wouldn’t actually bother doing) is to take the leaked Portal code and combine it with HL2 movement code to get something that better resembles Half-Life 2 with a portal gun rather than Portal with Half-Life 2 maps, since AFAIK (although I might be wrong) HL2DP has Portal movement, right?


#56

Yeah it’s all portal physics/glitches with HL2 maps. ABH when oob in HL2DP requires saveglitch for now, but this actually might be a good use for this version of portal.


#57

Any way to get this for HL:S? I’d like to do an HL1 done Portal run, having trouble porting in maps and textures.


#58

if you have hls on steam just copy the maps and textures over to portal and map c1a0 from the console.


#59

I mentioned this on the Talk page, but I guess I’ll mention this here as well. If you are downloading source unpack on a 32-bit machine, you might run into the 2GB limit, or the 2^31 - 1 byte limit. It could be a quirk of the specific configuration I was downloading with (linux + 32bit machine + *firefox *+ mega extention) – because I can create larger files with fallocate.

It could apprecated if we could bring this under the limit, so that people don’t spend an hour downloading it only to find out that their configuration doesn’t like it. This may not be possible, but could be worth looking into.

(Source: using terrible laptop to download Source Unpack in preperation for speedrun on another, better machine.)


#60

If I were to guess this is MEGA extension malfunctioning, because there should not be such a thing as 2 GB file limit, even on 32-bit systems. I don’t think it’s necessary to reduce the file size because you’re probably the first and last person to have this issue.