Source Unpack 2.3


#21

Yeah I already download those and did everything you said. Iv’e dealt with source splits many times and I see no reason why they are deciding not to work at all, but I think I might know why.


#22

Yup I totally was connected to the wrong exe lol my bad but it’s working now so yay ^^


#23

Eh just noticed:

And then:

May wanna edit that last post.


#24

Updated the Old Engine Unpack to be a Source Mod running 4044 rather than a separate game as 2707.

Did this because the 2707 unpack used a stupid combination of Steam DLLs from HL2 Episode 1 and Half Life 1, and it was super unstable (loading saves and maps caused crashes) for a lot of people.

I couldn’t find a way have 2707 work along side Steam properly, so the only option is to use 4044 as far as I can tell, there aren’t many major differences between the two versions but it’s still Old Engine, so enjoy forward Bhop!

Download

Readme

If the game crashes on any maps, please let me know.


#25

Nice. I hope you get the other versions as well. Volvo hasn’t replied unfortunatelly.


#26

Once Mu’s '04 retail version comes in, maybe we can find some way to get that working?


#27

Anyone else experiencing this weird train lag? Happens only on the OE unpack for me.


#28

Not sure why this happens but it also happens in canals 01 and sometimes on new engine.


#29

Switch off you hackz


#30

Feels like an autosave is making the game lag or something.


#31

Please help,
Whenever I try to start the .cmd I get:
SteamStartup() failed:Missing interface

I am using family share for steam and Tried to follow the instructions properly.


#32

You sure steam is running?


#33

If steam is running but you don’t own the game it should come up with a different error, I’m not sure that Steam Family Sharing works, because you have to be in a form of offline mode for it to work or something right? I’ve never tried it and wouldn’t know how to fix it.


#34

Yes.


#35

You don’t have to have post 3 separate replies.

Do you have SourceSDK and SourceSDK 2007 installed?


#36

don’t triple post


#37

Just installed it, I’ll try it now.
(Will edit / make replies all in one post next time, thanks for the tip.)

Edit:
Installing didn’t work, same “client and server .dlls are missing” error still pops up.


#38

Post a screenshot of the error, because I’ve never heard of that error before.


#39

Here,

http://imgur.com/gallery/DVbxk

Those two errors pop up then the game freezes and has to be closed using task manager.


#40

Try putting just “hl2oe” in the SteamApps folder, you’ve put it under a folder called sourceunpack, just remove it from that folder so it looks like “/steam/steamapps/sourcemods/hl2oe”.

If that doesn’t work it’s probably got something to do with Family Sharing, I’ve never seen an error like that before and trust me, I’ve seen lots of HL2 errors making this.